package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s+\w+\[(?<first_num>\d+)\]\w+\[(?<second_num>\d+)\][^\[]*\[(?<third_num>[^\]]*)\]`)
var str = `1:00:00 jon nginx: A[1234]B[56789] [0.1222]
11:00:00 dan service cloud: C[0078]D[12] F[2]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}