#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ":\d{2}(,|$)"
Local $sString = "12:00:00,11:30:00,10:30:00,10:00:00,09:30:00"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)