use strict;
my $str = '12:00:00,11:30:00,10:30:00,10:00:00,09:30:00';
my $regex = qr/:\d{2}(,|$)/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";