re = /,(?=(?:[^"]*"[^"]*")*[^"]*$)/m
str = 'test, a "comma,", bob, ",sam,",here
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end