use strict;
my $str = 'a b c d e f g h i j k l m n o p q r s t u v w x y z
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
stale
egg
bunnul
f
dfdfdfdf
bfbgfgf
gbvcb
bvvb
v bnbv
b\'sfgr2345092374
hjjjio
1234ABNGH
23123ibnnbiuysd
i
aaaaaaaaaaaaaaaaaa
';
my $regex = qr/([!-\~]*[aeiou][!-\~]*)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}