#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?:^|\s)" & @CRLF & _
"(\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b" & @CRLF & _
"\." & @CRLF & _
"\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b" & @CRLF & _
"\." & @CRLF & _
"\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b" & @CRLF & _
"\." & @CRLF & _
"\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b)" & @CRLF & _
"(?:$|\s)"
Local $sString = "0.0.0.0" & @CRLF & _
"192.168.1.1" & @CRLF & _
"127.0.0.1" & @CRLF & _
"255.255.255.255" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"256.0.0.0" & @CRLF & _
"0.256.0.0" & @CRLF & _
"0.0.256.0" & @CRLF & _
"0.0.0.256" & @CRLF & _
".0.0.0.0" & @CRLF & _
"0.0.0.0." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")