using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"(?:^|\s)
(\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b
\.
\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b
\.
\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b
\.
\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b)
(?:$|\s)";
        string input = @"0.0.0.0
192.168.1.1
127.0.0.1
255.255.255.255
256.0.0.0
0.256.0.0
0.0.256.0
0.0.0.256
.0.0.0.0
0.0.0.0.
";
        RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
        
        foreach (Match m in Regex.Matches(input, pattern, options))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}