# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=(\b\w+\.(?:\s+\w+|$)))"
test_str = "This study was aimed at designing production of isoeugenol and vanillin from eugenol of clove leaf oil and analyzing the potential product development financially. The specific objectives of this research work are: 1. Identify the isoeugenol and vanillin. 2. Model simulation of process design of isoeugenol and vanillin. 3. Study on financial feasibility and added value. This research is expected to provide maximum economic potential of eugenol to enhance the added value of clove leaf oil. The results showed that the FTIR and NMR products confirmed that isoeugenol and vanillin present in the synthesized product were identical to the reference standards. {FIND( @ngkbm_lb_to_kg , ., 0 )} )} , @ngkbm_lb_to_kg)} hello.world"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.