re = /"{1}(.*?)"{1}/
str = 'this is a "" && "string constant" and this "is another" one
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end