package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((?:(?:^|\.)(?:\d|[1-9]\d|1\d{2}|2[0-4]\d|25[0-5])){4})$`)
var str = `192.68.35.35`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}