$re = '/\\\\added\[.*\]\{(.*(?:\{.*\}.*)*)\}/U';
$str = 'Some example text with \\added[author]{text with curly braces{some text}..}
Some example text with \\added[author]{text without curly braces}
Some example text with \\added[author]{text with {}and {} and {}curly braces{some text}..}
Some example text with \\added[author]{text with {}and {} and {}curly braces{some text}..}}
Some example text with \\added[author]{text with {}and {} and {}curly braces{some text}..}{}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);