#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\..*? (?P<error>\w+)(?= )"
Local $sString = "2014-09-12 03:25:16.549: org.eclipse.jetty.server.AsyncHttpConnection WARN - Closing EndPoint making no progress:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")