package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)""[^"]*""|(")([^"]*)(")`)
var str = `This is some^"text".This is also some ""TEST TEXT""
This is some "text". This is also some ""TEST TEXT""`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}