#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?<postcode>|(?<outward>(?<area>\w{1,2}))(?<district>\d\w|\d{1,2}))(?:\s)?(?<inward>(?<sector>\d)(?<unit>\w\w))?"
Local $sString = "W1J 7NT" & @CRLF & _
"DE12 8HJ" & @CRLF & _
"SW1A 1AA" & @CRLF & _
"HD7 5UZ" & @CRLF & _
"CH5 3QW" & @CRLF & _
"W2 1JB " & @CRLF & _
"PL7 1RF" & @CRLF & _
"EH99 1SB" & @CRLF & _
"G58 1SB" & @CRLF & _
"JE3 1EP" & @CRLF & _
"" & @CRLF & _
"GIR 0AA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")