$re = '/^(http)(s?)\:.\N*.(\D{3})\/?(\N?)*/m';
$str = '
http:lahunda.com/np
https:lahunda.com/
http:lam123.com/
http:abd123.com
https:kk12kk.com/prpp
https:asda23.comoerce/
ppshttps:
hkttps:
hkps
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);