#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([-0-9a-zA-Z.+_]+\s?(?:@|\(at\)|\|at\||\(@\))\s?+[-0-9a-zA-Z.+_]+(?:\.|\(Dot\))(?:de|com|net|org))"
Local $sString = "text@text(Dot)de" & @CRLF & _
"text(@)text(Dot)de" & @CRLF & _
"text(at)text(Dot)de" & @CRLF & _
"text|at|text(Dot)de" & @CRLF & _
"" & @CRLF & _
"text@text.de" & @CRLF & _
"text(@)text.de" & @CRLF & _
"text(at)text.de" & @CRLF & _
"text|at|text.de" & @CRLF & _
"" & @CRLF & _
"text @ text.de" & @CRLF & _
"text (@) text.de" & @CRLF & _
"text (at) text.de" & @CRLF & _
"text |at| text.de"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")