package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([-0-9a-zA-Z.+_]+\s?(?:@|\(at\)|\|at\||\(@\))\s?+[-0-9a-zA-Z.+_]+(?:\.|\(Dot\))(?:de|com|net|org))`)
var str = `text@text(Dot)de
text(@)text(Dot)de
text(at)text(Dot)de
text|at|text(Dot)de
text@text.de
text(@)text.de
text(at)text.de
text|at|text.de
text @ text.de
text (@) text.de
text (at) text.de
text |at| text.de`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}