const regex = /([-0-9a-zA-Z.+_]+\s?(?:@|\(at\)|\|at\||\(@\))\s?+[-0-9a-zA-Z.+_]+(?:\.|\(Dot\))(?:de|com|net|org))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([-0-9a-zA-Z.+_]+\\s?(?:@|\\(at\\)|\\|at\\||\\(@\\))\\s?+[-0-9a-zA-Z.+_]+(?:\\.|\\(Dot\\))(?:de|com|net|org))', 'g')
const str = `text@text(Dot)de
text(@)text(Dot)de
text(at)text(Dot)de
text|at|text(Dot)de
text@text.de
text(@)text.de
text(at)text.de
text|at|text.de
text @ text.de
text (@) text.de
text (at) text.de
text |at| text.de`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}