$re = '/([-0-9a-zA-Z.+_]+\s?(?:@|\(at\)|\|at\||\(@\))\s?+[-0-9a-zA-Z.+_]+(?:\.|\(Dot\))(?:de|com|net|org))/';
$str = 'text@text(Dot)de
text(@)text(Dot)de
text(at)text(Dot)de
text|at|text(Dot)de
text@text.de
text(@)text.de
text(at)text.de
text|at|text.de
text @ text.de
text (@) text.de
text (at) text.de
text |at| text.de';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);