re = /([-0-9a-zA-Z.+_]+\s?(?:@|\(at\)|\|at\||\(@\))\s?+[-0-9a-zA-Z.+_]+(?:\.|\(Dot\))(?:de|com|net|org))/
str = 'text@text(Dot)de
text(@)text(Dot)de
text(at)text(Dot)de
text|at|text(Dot)de
text@text.de
text(@)text.de
text(at)text.de
text|at|text.de
text @ text.de
text (@) text.de
text (at) text.de
text |at| text.de'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end