use strict;
my $str = 'asdas=3243
asdasd[123]=addddddsda';
my $regex = qr/(?<=[\w\]\)])(=)(?=\w)/p;
my $subst = ' $1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";