import Foundation
let pattern = #"(?<=[\w\]\)])(=)(?=\w)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
asdas=3243
asdasd[123]=addddddsda
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" $1 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)