using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"FLAGSHARE[\S\s]*?\d\s*\d\n";
string substitution = @"";
string input = @"FLAGSHARE
xxxxxx
xxxxx, 1 2015
words....
FLAGSHARE
xxxxxx
xxxxx, 2 2015
words....
FLAGSHARE
xxxxxx
xxxxx, 3 2015
words....";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}