package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`FLAGSHARE[\S\s]*?\d\s*\d\n`)
var str = `FLAGSHARE
xxxxxx
xxxxx, 1 2015
words....
FLAGSHARE
xxxxxx
xxxxx, 2 2015
words....
FLAGSHARE
xxxxxx
xxxxx, 3 2015
words....`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}