#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(.)\1{9}$)[2-9]\d{9}$"
Local $sString = "0000000000" & @CRLF & _
"1111111111" & @CRLF & _
"2222222222" & @CRLF & _
"3333333333" & @CRLF & _
"4444444444" & @CRLF & _
"5555555555" & @CRLF & _
"6666666666" & @CRLF & _
"7777777777" & @CRLF & _
"8888888888" & @CRLF & _
"9999999999" & @CRLF & _
"0223231223" & @CRLF & _
"1234345545" & @CRLF & _
"9878712233"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")