const regex = /^(?!(.)\1{9}$)[2-9]\d{9}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(.)\\1{9}$)[2-9]\\d{9}$', 'gm')
const str = `0000000000
1111111111
2222222222
3333333333
4444444444
5555555555
6666666666
7777777777
8888888888
9999999999
0223231223
1234345545
9878712233`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}