using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"word(?!@)";
string input = @"mywordLLD OK
myword.dff OK
myword@ld Exclude";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}