#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "src="\/\/(?:https?:\/\/)?.*\/(.*?)\?rel=\d*""
Local $sString = "https://www.youtube.com/watch?v=6tBJO2KenCE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")