const regex = /src="\/\/(?:https?:\/\/)?.*\/(.*?)\?rel=\d*"/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('src="\\\/\\\/(?:https?:\\\/\\\/)?.*\\\/(.*?)\\?rel=\\d*"', '')
const str = `https://www.youtube.com/watch?v=6tBJO2KenCE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}