$re = '/src="\/\/(?:https?:\/\/)?.*\/(.*?)\?rel=\d*"/';
$str = 'https://www.youtube.com/watch?v=6tBJO2KenCE';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);