$re = '/^([\S ]+\n?.*?)([0-9]+[,.][0-9]{2})...$/mi';
$str = 'Ben
1x 1.32 1.32 OK
Mark
3x 0.50 1.50 FAIL
Johny
2x 1.20 2.40 OK';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);