package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<\/?\w+(:)\w+>`)
var str = `<data:data>
<another:data>Content:content</another:data>
<another:data>Content</another:data>
<another:data>Content</another:data>
<another:data>Name:Foo</another:data>
</data:data>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}