$re = '/(\d+)M/';
$str = '107S33M15H
33M100S
12M100H33M';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);