package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-Z]{2})\$`)
var str = `"US$40, AU$89, JP$200"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}