import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\S]*)[\\s]+([\\S]*[\\s]+[\\S]*)[\\s]+([0-9]{1,2})\\%";
final String string = "RY4 Asian Flavor 10-15%\n"
+ "RY4 Double Flavor 5%-15%\n"
+ "Smooth Flavor 2 drops per 5 ml\n"
+ "Spearmint Flavor <5% Very Strong\n"
+ "Strawberries and Cream Flavor 10-12%\n"
+ "Strawberry Flavor 3%-15%\n"
+ "Strawberry Kiwi 20% 1/5\n"
+ "Strawberry Ripe 15%\n"
+ "Sweet Cream Flavor 5-10% 4/5 recommended for combining fake butter taste\n"
+ "Sweet Tart: 10% 5/5 Tastes more like Smarties\n"
+ "Sweetener 2%-6%\n"
+ "Tangerine Flavor (oil based) 1-5% 5/5\n"
+ "Tiramisu Flavor 2-5% VERY strong\n"
+ "Toasted Almond Flavor 15%";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}