using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:(?:(?<!^)[ ])?[^*&@_#$\]\\\^\d ]+){1,3})$";
string input = @"Uwe
Uwe-Jens
Günther Kalle
Kalle Jens Chantal";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}