re = /^((?:(?:(?<!^)[ ])?[^*&@_#$\]\\\^\d ]+){1,3})$/m
str = 'Uwe
Uwe-Jens
Günther Kalle
Kalle Jens Chantal'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end