package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<toto>dogs) are the best (friends) of (humans), don't listen to what (cats) say\.`)
var str = `dogs are the best friends of humans, don't listen to what cats say.
`
var substitution = "$3 are the best slaves of $4, don't listen to what ${toto} say"
fmt.Println(re.ReplaceAllString(str, substitution))
}