use strict;
my $str = 'dogs are the best friends of humans, don\'t listen to what cats say.
';
my $regex = qr/(?<toto>dogs) are the best (friends) of (humans), don't listen to what (cats) say\./mp;
my $subst = '$3 are the best slaves of $4, don\'t listen to what ${toto} say';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";