// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<toto>dogs) are the best (friends) of (humans), don't listen to what (cats) say\.").unwrap();
let string = "dogs are the best friends of humans, don't listen to what cats say.
";
let substitution = "$3 are the best slaves of $4, don't listen to what ${toto} say";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}