using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^|\s)""[A-Za-z\s\,\.]+""(?=$|\s)";
string input = @"hello ""hello my name is Paul. I from Bobruisk trhjrthiruthurihtyruihyruithy"" ""hello"" trhrthv ""vfvfv"" ""ferrg""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}