re = /(?<=^|\s)"[A-Za-z\s\,\.]+"(?=$|\s)/
str = 'hello "hello my name is Paul. I from Bobruisk trhjrthiruthurihtyruihyruithy" "hello" trhrthv "vfvfv" "ferrg"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end