$re = '/^(?:(\d+(?:st|th|[rn]d))\s+Meeting\s*-\s*)?(.*?)\s*(?:\[(\d+\s+(?:January|February|March|April|May|June|July|August|September|November|December)\s+\d{4})\s+to\s+((?:\d{1,2}\s+(?:January|February|March|April|May|June|July|August|September|November|December)\s+\d{4}))\])?$/m';
$str = '24th Meeting - The quick brown fox [10 January 2012 to 26 September 2012]
12th Meeting - Lorem ipsum dolor sit amet';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);