import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Test((_[A-Za-z0-9]+)\\1*)";
final String string = "Test_Interface extends\n"
+ "Test_Interface_Foo_Bar {\n"
+ "Test_FooBar implements\n"
+ "Test_FooBarFoo_Bar_Bar_Foo";
final String subst = "\\\\";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}