const regex = /^Test((_[A-Za-z0-9]+)\1*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Test((_[A-Za-z0-9]+)\\1*)', 'gm')
const str = `Test_Interface extends
Test_Interface_Foo_Bar {
Test_FooBar implements
Test_FooBarFoo_Bar_Bar_Foo`;
const subst = `\\`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);