$re = '/\b([\d\.]+)[mkb%](?!\S)/i';
$str = '40m 50% 60k';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);