import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\s*([\\s\\S]*?)\\s*\\}";
final String string = "<!DOCTYPE html>\n"
+ "<html>\n"
+ " <body>\n"
+ " <button id=\"btn-get\">$.get()</button>\n"
+ " <script data-require=\"jquery\" data-semver=\"2.0.3\" src=\"http://code.jquery.com/jquery-2.0.3.min.js\"></script>\n"
+ " <script type=\"text/javascript\" charset=\"utf-8\"> \n"
+ " function getValue(element)\n"
+ " {\n"
+ " alert(element);\n"
+ " //end\n"
+ " }\n\n"
+ " var content, matched;\n"
+ " $('#btn-get').click(function(e) \n"
+ " {\n"
+ " $.get('abc.html', function(data) \n"
+ " {\n"
+ " content = data;\n"
+ " });\n"
+ " matched = String(content).match(\"getValue(.*)end\"); \n"
+ " console.log(matched);\n"
+ " });\n"
+ " </script>\n"
+ " </body>\n"
+ "</html>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}