use strict;
my $str = '<!DOCTYPE html>
<html>
<body>
<button id="btn-get">$.get()</button>
<script data-require="jquery" data-semver="2.0.3" src="http://code.jquery.com/jquery-2.0.3.min.js"></script>
<script type="text/javascript" charset="utf-8">
function getValue(element)
{
alert(element);
//end
}
var content, matched;
$(\'#btn-get\').click(function(e)
{
$.get(\'abc.html\', function(data)
{
content = data;
});
matched = String(content).match("getValue(.*)end");
console.log(matched);
});
</script>
</body>
</html>
';
my $regex = qr/{\s*([\s\S]*?)\s*}/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}