re = /{\s*([\s\S]*?)\s*}/
str = '<!DOCTYPE html>
<html>
<body>
<button id="btn-get">$.get()</button>
<script data-require="jquery" data-semver="2.0.3" src="http://code.jquery.com/jquery-2.0.3.min.js"></script>
<script type="text/javascript" charset="utf-8">
function getValue(element)
{
alert(element);
//end
}
var content, matched;
$(\'#btn-get\').click(function(e)
{
$.get(\'abc.html\', function(data)
{
content = data;
});
matched = String(content).match("getValue(.*)end");
console.log(matched);
});
</script>
</body>
</html>
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end