// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"{\s*([\s\S]*?)\s*}").unwrap();
let string = "<!DOCTYPE html>
<html>
<body>
<button id=\"btn-get\">$.get()</button>
<script data-require=\"jquery\" data-semver=\"2.0.3\" src=\"http://code.jquery.com/jquery-2.0.3.min.js\"></script>
<script type=\"text/javascript\" charset=\"utf-8\">
function getValue(element)
{
alert(element);
//end
}
var content, matched;
$('#btn-get').click(function(e)
{
$.get('abc.html', function(data)
{
content = data;
});
matched = String(content).match(\"getValue(.*)end\");
console.log(matched);
});
</script>
</body>
</html>
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}